22 abr. 2013

CCNA4: Desafio de integración de aptitudes

Hoy vuelvo con uno de esos super-mega ejercicios de Cisco, en esta ocasión es del Módulo4, para ser concretos el ejercicio 8.6.1.3
"Sólo" nos piden: Frame Relay, PPP, pap, chap, NAT, ACL, VLAN, VTP, STP...
Os dejo la imagen y después del salto la configuración que hay que poner a los Routers y a los Switches




HQ

enable
username HQ password ciscochap
conf t
hostname HQ

interface f0/0
ip address 10.0.1.1 255.255.255.0
no shutdown
exit
interface s0/0/0
encapsulation frame-relay
frame-relay lmi-type q933
no shutdown
exit
interface S0/0/0.41 point-to-point
ip address 10.255.255.1 255.255.255.252
frame-relay interface-dlci 41
exit
interface s0/0/0.42 point-to-point
ip address 10.255.255.5 255.255.255.252
frame-relay interface-dlci 42
exit
interface s0/0/0.43 point-to-point
ip address 10.255.255.9 255.255.255.252
frame-relay interface-dlci 43
exit
interface s0/0/1
ip address 10.255.255.253 255.255.255.252
clock rate 64000
encapsulation ppp
ppp authentication pap
ppp pap sent-username HQ password ciscopap
no shutdown
exit
interface s0/1/0
ip address 209.165.201.1 255.255.255.252
no shutdown
encapsulation ppp
ppp authentication chap
exit

ip access-list standard NAT_LIST
permit 10.0.0.0 0.255.255.255
exit
ip nat pool XYZCORP 209.165.200.241 209.165.200.245 netmask 255.255.255.248
ip nat inside source static 10.0.1.2 209.165.200.246
ip nat inside source list NAT_LIST pool XYZCORP overload
interface f0/0
ip nat inside
exit
interface s0/0/0.41
ip nat inside
exit
interface s0/0/0.42
ip nat inside
exit
interface s0/0/0.43
ip nat inside
exit
interface s0/0/1
ip nat inside
exit
interface s0/1/0
ip nat outside
exit

ip route 0.0.0.0 0.0.0.0 s0/1/0
ip route 10.4.5.0 255.255.255.0 s0/0/1

router eigrp 100
network 10.0.1.0
network 10.255.255.0
network 10.255.255.4
network 10.255.255.8
network 10.255.255.252
network 209.165.201.0
no auto-summary
passive-interface f0/0
passive-interface s0/1/0
passive-interface s0/0/1
exit

ip access-list extended FIREWALL
permit tcp any host 209.165.200.244 eq 80
permit tcp any any established
permit icmp any any echo-reply
deny ip any any
exit
interface s0/1/0
ip access-group FIREWALL in
exit

*******************************************

B1

enable
conf t
hostname B1

interface f0/0
no shutdown
exit
interface f0/0.10
encapsulation dot1q 10
ip address 10.1.10.1 255.255.255.0
no shutdown
exit
interface f0/0.20
encapsulation dot1q 20
ip address 10.1.20.1 255.255.255.0
no shutdown
exit
interface f0/0.30
encapsulation dot1q 30
ip address 10.1.30.1 255.255.255.0
no shutdown
exit
interface f0/0.88
encapsulation dot1q 88
ip address 10.1.88.1 255.255.255.0
no shutdown
exit
interface f0/0.99
encapsulation dot1q 99 native
ip address 10.1.99.1 255.255.255.0
no shutdown
exit
interface s0/0/0
encapsulation frame-relay
frame-relay lmi-type q933
ip address 10.255.255.2 255.255.255.252
no shutdown
ip summary-address eigrp 100 10.1.0.0 255.255.0.0
exit

ip route 0.0.0.0 0.0.0.0 10.255.255.1

router eigrp 100
network 10.0.0.0
no auto-summary
passive-interface f0/0.10
passive-interface f0/0.20
passive-interface f0/0.30
no passive-interface f0/0.88
passive-interface f0/0.99
exit

ip dhcp excluded-address 10.1.10.1 10.1.10.10
ip dhcp excluded-address 10.1.20.1 10.1.20.10
ip dhcp excluded-address 10.1.30.1 10.1.30.10
ip dhcp excluded-address 10.1.88.1 10.1.88.24

ip dhcp pool B1_VLAN10
network 10.1.10.0 255.255.255.0
default-router 10.1.10.1
dns-server 10.0.1.4
exit
ip dhcp pool B1_VLAN20
network 10.1.20.0 255.255.255.0
default-router 10.1.20.1
dns-server 10.0.1.4
exit
ip dhcp pool B1_VLAN30
network 10.1.30.0 255.255.255.0
default-router 10.1.30.1
dns-server 10.0.1.4
exit

--------

B1-S1

enable
conf t
hostname B1-S1

interface vlan 99
ip address 10.1.99.21 255.255.255.0
no shutdown
exit

vtp mode server
vtp domain xyzcorp
vtp password xyzvtp

vlan 10
name Admin
exit
vlan 20
name Sales
exit
vlan 30
name Production
exit
vlan 88
name Wireless
exit
vlan 99
name Mgmt&Native
exit

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit

ip default-gateway 10.1.99.1

spanning-tree vlan 1 priority 4096
spanning-tree vlan 10 priority 4096
spanning-tree vlan 20 priority 4096
spanning-tree vlan 30 priority 4096
spanning-tree vlan 88 priority 4096
spanning-tree vlan 99 priority 4096

--------

B1-S2

enable
conf t
hostname B1-S2

interface vlan 99
ip address 10.1.99.22 255.255.255.0
no shutdown
exit

vtp mode client
vtp domain xyzcorp
vtp password xyzvtp

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit
interface f0/6
switchport mode access
switchport access vlan 10
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
exit
interface f0/11
switchport mode access
switchport access vlan 20
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit
interface f0/16
switchport mode access
switchport access vlan 30
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit
interface f0/7
switchport mode access
switchport access vlan 88
exit

ip default-gateway 10.1.99.1

--------

B1-S3

enable
conf t
hostname B1-S3

interface vlan 99
ip address 10.1.99.23 255.255.255.0
no shutdown
exit

vtp mode client
vtp domain xyzcorp
vtp password xyzvtp

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit
interface f0/7
switchport mode access
switchport access vlan 88
exit

ip default-gateway 10.1.99.1

spanning-tree vlan 1,10,20,30,88,99 priority 8192

*******************************************

B2

enable
conf t
hostname B2

interface f0/0
no shutdown
exit
interface f0/0.10
encapsulation dot1q 10
ip address 10.2.10.1 255.255.255.0
no shutdown
exit
interface f0/0.20
encapsulation dot1q 20
ip address 10.2.20.1 255.255.255.0
no shutdown
exit
interface f0/0.30
encapsulation dot1q 30
ip address 10.2.30.1 255.255.255.0
no shutdown
exit
interface f0/0.88
encapsulation dot1q 88
ip address 10.2.88.1 255.255.255.0
no shutdown
exit
interface f0/0.99
encapsulation dot1q 99 native
ip address 10.2.99.1 255.255.255.0
no shutdown
exit
interface s0/0/0
encapsulation frame-relay
frame-relay lmi-type q933
ip address 10.255.255.6 255.255.255.252
no shutdown
ip summary-address eigrp 100 10.2.0.0 255.255.0.0
exit

ip route 0.0.0.0 0.0.0.0 10.255.255.5

router eigrp 100
network 10.0.0.0
no auto-summary
passive-interface f0/0.10
passive-interface f0/0.20
passive-interface f0/0.30
no passive-interface f0/0.88
passive-interface f0/0.99
exit

ip dhcp excluded-address 10.2.10.1 10.2.10.10
ip dhcp excluded-address 10.2.20.1 10.2.20.10
ip dhcp excluded-address 10.2.30.1 10.2.30.10
ip dhcp excluded-address 10.2.88.1 10.2.88.24

ip dhcp pool B2_VLAN10
network 10.2.10.0 255.255.255.0
default-router 10.2.10.1
dns-server 10.0.1.4
exit
ip dhcp pool B2_VLAN20
network 10.2.20.0 255.255.255.0
default-router 10.2.20.1
dns-server 10.0.1.4
exit
ip dhcp pool B2_VLAN30
network 10.2.30.0 255.255.255.0
default-router 10.2.30.1
dns-server 10.0.1.4
exit

--------

B2-S1

enable
conf t
hostname B2-S1

interface vlan 99
ip address 10.2.99.21 255.255.255.0
no shutdown
exit

vtp mode server
vtp domain xyzcorp
vtp password xyzvtp

vlan 10
name Admin
exit
vlan 20
name Sales
exit
vlan 30
name Production
exit
vlan 88
name Wireless
exit
vlan 99
name Mgmt&Native
exit

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit

ip default-gateway 10.2.99.1

spanning-tree vlan 1,10,20,30,88,99 priority 4096

--------

B2-S2

enable
conf t
hostname B2-S2

interface vlan 99
ip address 10.2.99.22 255.255.255.0
no shutdown
exit

vtp mode client
vtp domain xyzcorp
vtp password xyzvtp

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit
interface f0/6
switchport mode access
switchport access vlan 10
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
exit
interface f0/11
switchport mode access
switchport access vlan 20
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit
interface f0/16
switchport mode access
switchport access vlan 30
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit
interface f0/7
switchport mode access
switchport access vlan 88
exit

ip default-gateway 10.2.99.1

--------

B2-S3

enable
conf t
hostname B2-S3

interface vlan 99
ip address 10.2.99.23 255.255.255.0
no shutdown
exit

vtp mode client
vtp domain xyzcorp
vtp password xyzvtp

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit
interface f0/7
switchport mode access
switchport access vlan 88

exit

ip default-gateway 10.2.99.1

spanning-tree vlan 1,10,20,30,88,99 priority 8192

*******************************************

B3

enable
conf t
hostname B3

interface f0/0
no shutdown
exit
interface f0/0.10
encapsulation dot1q 10
ip address 10.3.10.1 255.255.255.0
no shutdown
exit
interface f0/0.20
encapsulation dot1q 20
ip address 10.3.20.1 255.255.255.0
no shutdown
exit
interface f0/0.30
encapsulation dot1q 30
ip address 10.3.30.1 255.255.255.0
no shutdown
exit
interface f0/0.88
encapsulation dot1q 88
ip address 10.3.88.1 255.255.255.0
no shutdown
exit
interface f0/0.99
encapsulation dot1q 99 native
ip address 10.3.99.1 255.255.255.0
no shutdown
exit
interface s0/0/0
encapsulation frame-relay ietf
frame-relay lmi-type ansi
ip address 10.255.255.10 255.255.255.252
no shutdown
ip summary-address eigrp 100 10.3.0.0 255.255.0.0
exit

ip route 0.0.0.0 0.0.0.0 10.255.255.9

router eigrp 100
network 10.0.0.0
no auto-summary
passive-interface f0/0.10
passive-interface f0/0.20
passive-interface f0/0.30
no passive-interface f0/0.88
passive-interface f0/0.99
exit

ip dhcp excluded-address 10.3.10.1 10.3.10.10
ip dhcp excluded-address 10.3.20.1 10.3.20.10
ip dhcp excluded-address 10.3.30.1 10.3.30.10
ip dhcp excluded-address 10.3.88.1 10.3.88.24

ip dhcp pool B3_VLAN10
network 10.3.10.0 255.255.255.0
default-router 10.3.10.1
dns-server 10.0.1.4
exit
ip dhcp pool B3_VLAN20
network 10.3.20.0 255.255.255.0
default-router 10.3.20.1
dns-server 10.0.1.4
exit
ip dhcp pool B3_VLAN30
network 10.3.30.0 255.255.255.0
default-router 10.3.30.1
dns-server 10.0.1.4
exit

--------

B3-S1

enable
conf t
hostname B3-S1

interface vlan 99
ip address 10.3.99.21 255.255.255.0
no shutdown
exit

vtp mode server
vtp domain xyzcorp
vtp password xyzvtp

vlan 10
name Admin
exit
vlan 20
name Sales
exit
vlan 30
name Production
exit
vlan 88
name Wireless
exit
vlan 99
name Mgmt&Native
exit

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit

ip default-gateway 10.3.99.1

spanning-tree vlan 1,10,20,30,88,99 priority 4096

--------

B3-S2

enable
conf t
hostname B3-S2

interface vlan 99
ip address 10.3.99.22 255.255.255.0
no shutdown
exit

vtp mode client
vtp domain xyzcorp
vtp password xyzvtp

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit
interface f0/6
switchport mode access
switchport access vlan 10
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
exit
interface f0/11
switchport mode access
switchport access vlan 20
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit
interface f0/16
switchport mode access
switchport access vlan 30
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit
interface f0/7
switchport mode access
switchport access vlan 88
exit

ip default-gateway 10.3.99.1

--------

B3-S3

enable
conf t
hostname B3-S3

interface vlan 99
ip address 10.3.99.23 255.255.255.0
no shutdown
exit

vtp mode client
vtp domain xyzcorp
vtp password xyzvtp

interface range f0/1-5
switchport mode trunk
switchport trunk native vlan 99
no shutdown
exit
interface f0/7
switchport mode access
switchport access vlan 88
exit

ip default-gateway 10.3.99.1

spanning-tree vlan 1,10,20,30,88,99 priority 8192

************************

EN LOS ROUTERS WIRELESS


Setup -> Ip address: 10.X.40.1
Wireless -> SSID: BX-WRS_LAN
Wireless security -> Security mode: WEP; Key1: 12345ABCDE
Administration -> Router password: cisco123; Remote management: Enable
Status -> Release; Renew

Y sin más me despido como siempre, no sin antes recordaros que comentar es gratis :-)

9 comentarios :

  1. Hola Sofí!! Te traigo otra pesadilla en forma de premio bloguero jijiji
    Así que pásate por aquí a recogerlo http://acericuymandil.blogspot.com.es/2013/04/premio-best-blog.html
    Bss,
    Ra

    ResponderEliminar
  2. Hola que tal, tengo un problema, no se si me puedas ayudar, solo pude completer el 99% de la practica. Me marca un error en el Default Gateway de los Routers inhalambricos, y no le encuentro, algo extraño que me sucedio es en el ultimo paso que comentas con respect a

    Status -> Release; Renew

    no sucedio nada cuando presione esos botonoes en el GUI
    que podra ser?

    ResponderEliminar
    Respuestas
    1. Creo que fue en este mismo ejercicio, a compañeros de clase les pasaba lo mismo que me comentas, a fuerza de dar Release, Renew y Refresh a algunos les funcionó (locuras del Packet Tracert).
      De todas maneras te dejo el enlace al ejercicio al 100%
      https://dl.dropboxusercontent.com/u/104502711/8.6.1.pka?dl=1

      Eliminar
  3. Respuestas
    1. Lo acabo de postear
      http://soydeoviedo.blogspot.com.es/2013/12/ccna-3-reto-de-habilidades-de.html

      Eliminar
  4. Amigo, en relación a tu problema
    los router Inalambricos no estan recibiendo IP mediante DHCP ya que falta configurar

    B3(config)#ip dhcp pool B3_VLAN88
    B3(dhcp-config)#network 10.3.88.0 255.255.255.0
    B3(dhcp-config)#dns-server 10.0.1.4
    B3(dhcp-config)#default-router 10.3.88.1

    (ememplazar 3 en los router 1 y 2)

    ResponderEliminar